<!DOCTYPE html>
<html prefix="
og: http://ogp.me/ns#
article: http://ogp.me/ns/article#
" lang="en">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>Soloists: code review on a solo project | Will's blog</title>
<link href="../assets/css/bootstrap.min.css" rel="stylesheet" type="text/css">
<link href="../assets/css/rst.css" rel="stylesheet" type="text/css">
<link href="../assets/css/code.css" rel="stylesheet" type="text/css">
<link href="../assets/css/colorbox.css" rel="stylesheet" type="text/css">
<link href="../assets/css/theme.css" rel="stylesheet" type="text/css">
<meta name="theme-color" content="#5670d4">
<meta name="generator" content="Nikola (getnikola.com)">
<link rel="alternate" type="application/rss+xml" title="RSS" href="../rss.xml">
<link rel="canonical" href="http://bluesock.org/~willkg/blog/mozilla/soloists_code_review.html">
<!--[if lt IE 9]><script src="../assets/js/html5.js"></script><![endif]--><meta name="author" content="Will Kahn-Greene">
<link rel="prev" href="antenna_project_wrapup.html" title="Antenna: post-mortem and project wrap-up" type="text/html">
<meta property="og:site_name" content="Will's blog">
<meta property="og:title" content="Soloists: code review on a solo project">
<meta property="og:url" content="http://bluesock.org/~willkg/blog/mozilla/soloists_code_review.html">
<meta property="og:description" content="Summary
I work on some projects with other people, but I also spend a lot of time
working on projects by myself. When I'm working by myself, I have difficulties
with the following:

code review
bounci">
<meta property="og:type" content="article">
<meta property="article:published_time" content="2017-07-24T12:00:00-04:00">
<meta property="article:tag" content="mozilla">
<meta property="article:tag" content="python">
<meta property="article:tag" content="soloists">
<meta property="article:tag" content="work">
</head>
<body>
<a href="#content" class="sr-only sr-only-focusable">Skip to main content</a>

<!-- Menubar -->

<nav class="navbar navbar-inverse navbar-static-top"><div class="container">
<!-- This keeps the margins nice -->
        <div class="navbar-header">
            <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-navbar" aria-controls="bs-navbar" aria-expanded="false">
            <span class="sr-only">Toggle navigation</span>
            <span class="icon-bar"></span>
            <span class="icon-bar"></span>
            <span class="icon-bar"></span>
            </button>
            <a class="navbar-brand" href="http://bluesock.org/~willkg/blog/">

                <span id="blog-title">Will's blog</span>
            </a>
        </div>
<!-- /.navbar-header -->
        <div class="collapse navbar-collapse" id="bs-navbar" aria-expanded="false">
            <ul class="nav navbar-nav">
<li>
<a href="http://bluesock.org/~willkg/">Home</a>
                </li>
<li>
<a href="../archive.html">Archive</a>
                </li>
<li>
<a href="../tag/index.html">Tags</a>
                </li>
<li>
<a href="../rss.xml">RSS feed</a>

                
            </li>
</ul>
<ul class="nav navbar-nav navbar-right">
<li>
    <a href="soloists_code_review.rst" id="sourcelink">Source</a>
    </li>
                
            </ul>
</div>
<!-- /.navbar-collapse -->
    </div>
<!-- /.container -->
</nav><!-- End of Menubar --><div class="container" id="content" role="main">
    <div class="body-content">
        <!--Body content-->
        <div class="row">
            
<article class="post-text h-entry hentry postpage" itemscope="itemscope" itemtype="http://schema.org/Article"><header><h1 class="p-name entry-title" itemprop="headline name"><a href="#" class="u-url">Soloists: code review on a solo project</a></h1>

        <div class="subtitle">
            <time class="published dt-published" datetime="2017-07-24T12:00:00-04:00" itemprop="datePublished" title="Monday July 24, 2017 12:00">Monday July 24, 2017 12:00</time>,
            <span class="byline-name fn">Will Kahn-Greene</span>
            |
            <a href="http://twitter.com/intent/tweet?url=http%3A//bluesock.org/%7Ewillkg/blog/mozilla/soloists_code_review.html&amp;text=Soloists%3A%20code%20review%20on%20a%20solo%20project&amp;via=willcage">Tweet this</a>
        </div>
        
    </header><div class="e-content entry-content" itemprop="articleBody text">
    <div>
<div class="section" id="summary">
<h2>Summary</h2>
<p>I work on some projects with other people, but I also spend a lot of time
working on projects by myself. When I'm working by myself, I have difficulties
with the following:</p>
<ol class="arabic simple">
<li>code review</li>
<li>bouncing ideas off of people</li>
<li>peer programming</li>
<li>long slogs</li>
<li>getting help when I'm stuck</li>
<li>publicizing my work</li>
<li>dealing with loneliness</li>
<li>going on vacation</li>
</ol>
<p>I started a <tt class="docutils literal">#soloists</tt> group at Mozilla figuring there are a bunch of other
Mozillians who are working on solo projects and maybe if we all work alone
together, then that might alleviate some of the problems of working solo. We
hang out in the <tt class="docutils literal">#soloists</tt> IRC channel on irc.mozilla.org. If you're solo,
join us!</p>
<p>I keep thinking about writing a set of blog posts for things we've talked about
in the channel and how I do things. Maybe they'll help you.</p>
<p>This one covers code review.</p>
<!-- TEASER_END -->
</div>
<div class="section" id="code-review-on-a-solo-project">
<h2>Code review on a solo project</h2>
<p><a class="reference external" href="http://pyvideo.org/pycon-us-2017/constructive-code-review.html">Erik Rose's Constructive Code Review</a> talk at PyCon
US 2017 is a fantastic talk covering why you should do code review and how to
effectively and constructively review code.</p>
<p>In the video, Erik talks about the three reasons you should be doing code
review:</p>
<ol class="arabic simple">
<li>Build an excellent product.</li>
<li>Build people.</li>
<li>Build yourself.</li>
</ol>
<p>That's awesome! Who wouldn't want that?</p>
<p>But what do you do if you're solo? The whole basis of code review is that
<em>someone else</em> reviews the code, so what if there is no one else? Maybe you're
working on a solo project at work. Maybe you're starting a new open source
project that hasn't picked up contributors.</p>
<p>I think projects differ greatly in a variety of ways. For some projects, there
is no substitute for having someone else knowledgeable in the project review
your code. If you're solo on a project like that, you're pretty stuck without
help. For all the other projects, I think there are some things you can do to at
least get by and help build an excellent product.</p>
<p>I work mostly in Python, so what I do works in Python land for software
development projects. If you're not doing software development or not using
Python, then you might have to adjust accordingly.</p>
</div>
<div class="section" id="how-we-re-going-to-talk-about-code-reviews">
<h2>How we're going to talk about code reviews</h2>
<p>Code reviews can/should look at many aspects of the code change. I'm going to
bucket these roughly into the following five categories:</p>
<ol class="arabic simple">
<li>
<strong>developer best practices</strong>: tests, documentation, development artifacts</li>
<li>
<strong>programming language/library best practices</strong>: APIs, thread-safety
properties, data structures, design patterns</li>
<li>
<strong>project conventions</strong>: code style, what stuff goes where</li>
<li>
<strong>project experience</strong>: anything that requires experience with the project
to know like past decisions, goals and non-goals, and project history</li>
<li>
<strong>unknown unknowns</strong>: things you don't know</li>
</ol>
</div>
<div class="section" id="before-you-do-anything-get-a-linter">
<h2>Before you do anything, get a linter</h2>
<p>Linters and static analyzers are super.</p>
<p>I set up linters to cover as many things as I can that I care about. Here
are some of the ones I use:</p>
<ul>
<li>
<p class="first"><a class="reference external" href="https://pypi.python.org/pypi/flake8">flake8</a>: Covers style and some other
issues.</p>
<p>flake8 supports plugins, too. There are <a class="reference external" href="https://pypi.python.org/pypi?%3Aaction=search&amp;term=flake8&amp;submit=search">lots of really great ones on pypi</a>.
Definitely worth looking through them and adding whatever helps you.</p>
<p>Might be worth writing your own for stuff you want that doesn't exist.</p>
</li>
<li>
<p class="first"><a class="reference external" href="https://pypi.python.org/pypi/bandit">bandit</a>: Security oriented analyzer.
This is helpful to run. It generates a lot of false positives for me, but it
picks up good stuff, too.</p>
</li>
<li>
<p class="first"><a class="reference external" href="https://pypi.python.org/pypi/check-manifest">check-manifest</a>: Checks
MANIFEST.in files.</p>
</li>
</ul>
<p>Anything I can automatically check via a linter is one less thing I have to
think about <a class="footnote-reference" href="soloists_code_review.html#id2" id="id1">[1]</a>.</p>
<p>Plus I usually have a shell script or a make rule or a tox environment or
something that runs all the linters in sequence which I can do before I create a
pull request.</p>
<p>Some linters integrate with code editors, so you can see issues as you type
them.</p>
<p>You can use linters with CI systems, so they can prevent problems from getting
merged.</p>
<table class="docutils footnote" frame="void" id="id2" rules="none">
<colgroup>
<col class="label">
<col>
</colgroup>
<tbody valign="top"><tr>
<td class="label"><a class="fn-backref" href="soloists_code_review.html#id1">[1]</a></td>
<td>Unless the linter has a bug and then woo-hoo clown shoes!</td>
</tr></tbody>
</table>
</div>
<div class="section" id="how-to-find-someone-to-review-your-code">
<h2>How to find someone to review your code</h2>
<p>For developer best practices and programming language/library best practices,
here are some ways to find someone to review your code:</p>
<ol class="arabic simple">
<li>ask a mentor</li>
<li>ask people you have 1:1 meetings with <a class="footnote-reference" href="soloists_code_review.html#id4" id="id3">[2]</a>; run code by them or try rubber
ducking explanations because they might ask questions that surface issues and
suggest better ways to do things</li>
<li>ask people working on similar projects, perhaps other projects at the same
company you're at or other projects that use the same programming language
and libraries; try trading reviews with someone in this group</li>
<li>ask for help from a community on the Internet like <a class="reference external" href="https://codereview.stackexchange.com/">Code Review</a>
</li>
<li>ask for help at a hackfest, user group, conference, or meetup group</li>
</ol>
<p>Sometimes those sources can help with the unknowns, too.</p>
<p>If you're solo, then you're probably the only person with experience in your
project, so covering that aspect of code reviews is tough.</p>
<p>For open source projects, you could ask for help from someone who works on a
similar project. For example, if you're working on a PEG parsing library and you
go to a PyCon conference, find other people who've worked on parsers and ask to
trade reviews.</p>
<p>Keep in mind that if you're asking for help from people who don't normally help
you, it's best to keep your changes as small as possible. You won't make friends
by asking people to review 1,000+ line changes.</p>
<table class="docutils footnote" frame="void" id="id4" rules="none">
<colgroup>
<col class="label">
<col>
</colgroup>
<tbody valign="top"><tr>
<td class="label"><a class="fn-backref" href="soloists_code_review.html#id3">[2]</a></td>
<td>I have 1:1s with people doing totally different things than I am because
we learn a lot from each other and have vastly different perspectives on
things. More on this in a different post.</td>
</tr></tbody>
</table>
</div>
<div class="section" id="how-to-approximate-code-review-with-a-self-review">
<h2>How to approximate code review with a self-review</h2>
<p>Is self review a substitute for someone else reviewing your code? Definitely
not, but the premise here is that you're on a solo project and there isn't a
someone else. If you've exhausted the world's options, then you're just going to
have to get the best approximation you can get.</p>
<div class="section" id="my-development-process-leading-up-to-code-review">
<h3>My development process leading up to code review</h3>
<p>Code review is just one step in the development process. I find code review
is easier and less risky if I follow these rules:</p>
<ol class="arabic">
<li>
<p class="first">Research, think, and plan as much as possible before coding.</p>
</li>
<li>
<p class="first">Talk to myself about what I'm doing. A lot.</p>
</li>
<li>
<p class="first">Keep changes small.</p>
<p>The larger a change is, the longer it takes to review and the higher risk
of introducing bugs and failures.</p>
<p>Sometimes I'll break up changes into a set of smaller atomic changes.
Sometimes forcing myself to think about breaking big changes into small
atomic changes makes it easier to do big changes.</p>
</li>
</ol>
</div>
<div class="section" id="my-self-review-flow">
<h3>My self-review flow</h3>
<p>I think those three things create a context in which it's easier to do
self-review.</p>
<p>For self-review, this is roughly what I do:</p>
<ol class="arabic">
<li>
<p class="first"><strong>I run all the linters and tests I have set up for the project.</strong></p>
<p>This covers project conventions and makes sure everything is good as far as
computers can tell. Forcing computers to do work means I do less.</p>
</li>
<li>
<p class="first"><strong>I go take a walk and do something somewhere else for 15 minutes.</strong></p>
<p>This is a good time to get a glass of water <a class="footnote-reference" href="soloists_code_review.html#id6" id="id5">[3]</a>. I work at home, so
sometimes I'll spend some time decluttering or cleaning.</p>
</li>
<li>
<p class="first"><strong>I look at the changes in different ways using different tools.</strong></p>
<p>When I come back, I try to look at the code changes in a bunch of different
ways and see if it looks ok.</p>
<p>I do:</p>
<pre class="literal-block">
git diff master..HEAD
</pre>
<p>or something equivalent in the terminal and read through my changes
carefully. git has a variety of different diffing and ways to view. For
example:</p>
<pre class="literal-block">
git diff --histogram master..HEAD
git diff --minimal master..HEAD
git diff --patience master..HEAD
git diff --word-diff=color master..HEAD
</pre>
<p>Definitely worth reading through <tt class="docutils literal">git diff <span class="pre">--help</span></tt> to see what would help
you.</p>
<p>I may also look at each individual commit and the commit comments and
summary.</p>
<p>I may look at the original code in full (checkout the master branch) and then
look at the changed code in full (checkout the branch tip).</p>
<p>Looking at the changes using different tools and views helps force my brain
to be more careful reading because it looks totally different. Different
tools use different diffing algorithms, have different fonts and color
schemes, and show different amounts of context.</p>
<p>This sort of covers developer best practices, programming language/library
best practices, and things that require someone who's been working on the
project for a while.</p>
</li>
<li>
<p class="first"><strong>Fourth, I push my branch and create a pull request on GitHub.</strong></p>
<p>The CI system I use (<a class="reference external" href="https://circleci.com/">Circle CI</a> or <a class="reference external" href="https://travisci.com/">Travis CI</a> depending on the project) happily runs all my tests
and linters.</p>
<p>If there are CI failures, I'll fix them.</p>
</li>
<li>
<p class="first"><strong>I leave it for a day.</strong></p>
<p>I'll do other things and ignore the PR until the following day. A night of
sleep between creating the PR and reviewing it gives me time to mull over
things and helps me forget bits.</p>
<p>Sometimes I get side-tracked on something else--I usually have multiple
projects I'm working on, so I'll switch between them.</p>
</li>
<li>
<p class="first"><strong>I review my pull request.</strong></p>
<p>I go through the pull request carefully and answer questions like the
following: questions:</p>
<ol class="arabic">
<li>
<p class="first">How can this code fail? What have I done to prevent those failures? What
have I done to surface those failures so I know if they're happening?</p>
</li>
<li>
<p class="first">What happens if this code is wrong? Will it cause data loss? Will it break
the service-level agreement I have with my users? Can this change be
backed out quickly if it's bad?</p>
</li>
<li>
<p class="first">Are these changes appropriately covered by the tests? Do the tests make
sense?</p>
<p>If I'm using mocks in my tests, have I verified that the mocks are
correct?</p>
</li>
<li>
<p class="first">Do the changes match the documentation and surrounding comments?</p>
</li>
</ol>
<p>I take my time reviewing my pull requests. I don't rush it. If I'm tired, I
take a break.</p>
<p>I write comments to my PRs especially to explain design decisions that I
think might look odd. Future me and any other developers that join this
project will benefit greatly from me explaining why I did what I did. Also,
this is sort of like rubber-ducking and I sometimes discover things I should
change because they're either hard to explain or it becomes clear it's
missing edge cases.</p>
<p>This sort of covers developer best practices, programming language/library
best practices, and things that require someone who's been working on the
project for a while, too.</p>
</li>
<li>
<p class="first"><strong>I land the change!</strong></p>
<p>After all that, I'll land the change. If there are issues, I'll fail forward
and fix them if I can. If I can't do that, I'll back it out. I don't think
I've ever backed anything out, though.</p>
</li>
</ol>
<p>That's pretty much it.</p>
<p>Periodically, I revisit code a couple of weeks or a month later and see if it
still looks ok. Sometimes code doesn't evolve well over time and is worth
refactoring.</p>
<table class="docutils footnote" frame="void" id="id6" rules="none">
<colgroup>
<col class="label">
<col>
</colgroup>
<tbody valign="top"><tr>
<td class="label"><a class="fn-backref" href="soloists_code_review.html#id5">[3]</a></td>
<td>It's good to drink water.</td>
</tr></tbody>
</table>
</div>
<div class="section" id="do-i-do-all-these-steps-every-time">
<h3>Do I do all these steps every time?</h3>
<p>No. I try to balance the urgency of the change to land with the risks of failure
with the consequences of failure and base how much time I should spend reviewing
on that.</p>
<p>For example, if I'm fixing documentation, I won't spend a lot of time reviewing
it. If I'm fixing a critical method in a piece of code that needs to be
thread-safe and never fail, then I'll take a couple of days and be more
meticulous.</p>
</div>
<div class="section" id="warning-self-review-doesn-t-help-you-build-people-or-build-yourself">
<h3>Warning: Self-review doesn't help you build people or build yourself!</h3>
<p>In a self-review, you're both the developer and the reviewer. That bites you
in both directions.</p>
<p>When you review other peoples' code, you share your experience and knowledge
with them and help them grow as a developer and grow as a contributor on your
project. If you're self-reviewing, you're not growing anyone.</p>
<p>When someone else reviews your code, they share their experience and knowledge
with you and cover the things that are unknown to you. Thus code review is a
unique opportunity to learn from others and grow as a developer. If you're
self-reviewing, you're not growing yourself.</p>
<p>If you're self-reviewing, you need to work harder to alleviate these missed
opportunities.</p>
</div>
</div>
<div class="section" id="many-thanks">
<h2>Many thanks</h2>
<p>Many thanks to the <tt class="docutils literal">#soloists</tt> who I've bandied about some of these thoughts
with over the last year and those who read this and provided feedback. Many
many thanks to Erik who studiously reviewed earlier drafts and pointed out
many issues.</p>
</div>
<div class="section" id="what-do-you-do">
<h2>What do you do?</h2>
<p>Ever worked on a solo project? What do you do to alleviate the problems of not
having someone else to review code?</p>
<p>Let me know and I'll update this with your thoughts.</p>
</div>
</div>
    </div>
    <section class="comments">
        Want to comment? Send an email to <em>willkg at bluesock dot
        org</em>. Include the url for the blog entry in your comment so I have
        some context as to what you're talking about.
    </section><aside class="postpromonav"><nav><ul itemprop="keywords" class="tags">
<li><a class="tag p-category" href="../tag/mozilla.html" rel="tag">mozilla</a></li>
            <li><a class="tag p-category" href="../tag/python.html" rel="tag">python</a></li>
            <li><a class="tag p-category" href="../tag/soloists.html" rel="tag">soloists</a></li>
            <li><a class="tag p-category" href="../tag/work.html" rel="tag">work</a></li>
        </ul>
<ul class="pager hidden-print">
<li class="previous">
                <a href="antenna_project_wrapup.html" rel="prev" title="Antenna: post-mortem and project wrap-up">Previous post</a>
            </li>
        </ul></nav></aside></article>
</div>
        <!--End of body content-->

        <footer id="footer">
            Contents © 1996 to 2017 Will Kahn-Greene - Powered by <a href="https://getnikola.com" rel="nofollow">Nikola</a> CC BY-SA 3.0
            
        </footer>
</div>
</div>

            <script src="../assets/js/jquery.min.js"></script><script src="../assets/js/bootstrap.min.js"></script><script src="../assets/js/moment-with-locales.min.js"></script><script src="../assets/js/fancydates.js"></script><script src="../assets/js/jquery.colorbox-min.js"></script><script>$('a.image-reference:not(.islink) img:not(.islink)').parent().colorbox({rel:"gal",maxWidth:"100%",maxHeight:"100%",scalePhotos:true});</script><!-- fancy dates --><script>
    moment.locale("en");
    fancydates(0, "YYYY-MM-DD HH:mm");
    </script><!-- end fancy dates -->
</body>
</html>
